Today I have been ?????????????? to my classic

Here's the place to chat about all things classic. Also includes a feedback forum where you can communicate directly with the editorial team - don't hold back, they'd love to know what they're doing right (or wrong of course!)
Message
Author
User avatar
SirTainleyBarking
Posts: 413
Joined: Mon Feb 14, 2011 12:41 am
Location: Solihull, where Landrovers come from

Re: Today I have been ?????????????? to my classic

#391 Post by SirTainleyBarking » Sun Feb 07, 2016 8:19 pm

Prepping up the 300TDi.
According to the experts, the fusebox mounting bracket on the inner wing, never rots, and any minor corrosion can be easily rectified.

I disagree, and I have evidence to back up that assertion
grot 1.jpg
grot 1.jpg (84.78 KiB) Viewed 1489 times
grot 2.jpg
grot 2.jpg (81.44 KiB) Viewed 1489 times
3 pauses whilst dodging the rain, and patching a couple of holes that appeared whilst cleaning up - It's a Landrover, so what did you expect?

Next job is patch the inner wing bottom and replace the battery tray, but hopefully not on a day when it's urinating down
Landrovers and Welding go together like Bread and Butter. And in the wet they are about as structurally sound

Biting. It's like kissing except there's a winner

rich.
Posts: 6804
Joined: Wed Jan 05, 2011 9:18 pm

Re: Today I have been ?????????????? to my classic

#392 Post by rich. » Sun Feb 07, 2016 10:10 pm

thats crusty!

GHT
Posts: 1216
Joined: Mon Jan 26, 2015 3:09 pm

Re: Today I have been ?????????????? to my classic

#393 Post by GHT » Sun Feb 07, 2016 10:41 pm

rich. wrote:thats crusty!
Not half as crusty as the purest brigade will be when they read this and find out that not only have I changed the old crossplies to radials, but now, the MG's light bulbs are LED. :shock: There will be letters to The Times.

rich.
Posts: 6804
Joined: Wed Jan 05, 2011 9:18 pm

Re: Today I have been ?????????????? to my classic

#394 Post by rich. » Mon Feb 08, 2016 1:16 am

GHT wrote:
rich. wrote:thats crusty!
Not half as crusty as the purest brigade will be when they read this and find out that not only have I changed the old crossplies to radials, but now, the MG's light bulbs are LED. :shock: There will be letters to The Times.
never mind letters to the times watch out for lynch mobs or peasants with pitch forks :scared:

rich.
Posts: 6804
Joined: Wed Jan 05, 2011 9:18 pm

Re: Today I have been ?????????????? to my classic

#395 Post by rich. » Tue Feb 16, 2016 9:47 pm

not a classic, but...
replaced the rear seat belt buckle on the clio yesterday.. window got broken & some glass got in the old one.. many thanks to france pare brise for that one :evil: broken glass was everywhere after they replaced a side screen last summer.. i cleaned the car out last week :oops:

GHT
Posts: 1216
Joined: Mon Jan 26, 2015 3:09 pm

Re: Today I have been ?????????????? to my classic

#396 Post by GHT » Wed Feb 17, 2016 8:28 am

rich. wrote:broken glass was everywhere after they replaced a side screen last summer.. i cleaned the car out last week :oops:
No more crunchy bum every time you sit in the car now.

rich.
Posts: 6804
Joined: Wed Jan 05, 2011 9:18 pm

Re: Today I have been ?????????????? to my classic

#397 Post by rich. » Wed Feb 17, 2016 9:32 am

:lol: :lol:

Young Farmer
Posts: 151
Joined: Wed Jan 26, 2011 8:27 pm

Re: Today I have been ?????????????? to my classic

#398 Post by Young Farmer » Sun Apr 03, 2016 8:20 pm

Took the hydrogas displacers off the Maxi as the ride had gone quite harsh to have them modified to enable them to be regassed. Taking a few days off and taking them to Telford to have them done. Had to remove the radiator to get at the n/s front unit and found that the core fins are turning to dust. Will have that done before refitting it.

sierra3dr
Posts: 415
Joined: Fri Feb 11, 2011 10:20 am

Re: Today I have been ?????????????? to my classic

#399 Post by sierra3dr » Sat Apr 09, 2016 12:39 am

decided to renew the accelerator pump diaphragm and the accelerator pump accumulator diaphragm on my MK5 Cortiina. Long over due,kept putting it off. The AP diaphragm was split,more than likely that was the cause of poor fuel economy.

User avatar
UKJeeper
Posts: 787
Joined: Sat May 04, 2013 8:37 am

Re: Today I have been ?????????????? to my classic

#400 Post by UKJeeper » Wed Apr 13, 2016 2:37 pm

Successfully renewing the MOT on the YJ!

Now I just have to fix the leaky water pump gasket, again!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest