Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

Post pictures and stories about your cars both present and past. Also post up "blogs" on your restoration projects - the more pictures the better! Note: blog-type threads often get few replies, but are often read by many members, and provide interest and motivation to other enthusiasts so don't be disappointed if you don't get many replies.
Message
Author
Dick
Posts: 504
Joined: Wed Sep 11, 2019 7:31 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#661 Post by Dick » Sat Aug 08, 2020 12:20 pm

JPB wrote:
Fri Aug 07, 2020 10:05 am
Zelandeth wrote:
Fri Aug 07, 2020 12:44 am
...

They can go occupy themselves looking at the seven digit price tag Ferraris with carefully polished and rotationally matched spark plugs. I'll stick with the cars with a story to tell.
Amen to that! :)
Exactly!

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#662 Post by Zelandeth » Sun Aug 09, 2020 10:05 pm

Needed to venture out today to get some more dog food which meant a trip right down the the south edge of MK. The Jag is massively too hot in this weather as the air con isn't sorted yet, Xantia is still at the garage and the van needs fuel. Will be taking the Invacar then.

Think it's fair to say that the last couple of runs have helped confidence as I didn't hesitate to take the quick (if actually slightly longer) route straight down the A5 to Caldecotte then across to Walnut Tree from there, and the same route back. Again no issues to report though as any other owners will attest to, the CVT belt section does make a horrendous din at speed. I think that's something which adding some soft trim to the cabin will help massively as it's just white noise which just reverberates around the cabin horribly.

Image

Oh, finally got around to actually fitting the offside gutter infill strip that I cut to size months ago, started to fit then realised I couldn't reach the far end in the garage.

Image

Think it's nice to have something to break up the otherwise solid block of blue.

Not needing your feet for anything frees up a lot of floor as cargo space...

Image

When we got home I decided to give her a much needed wash. There were still greasy handprints and such like all over the car plus no small amount of sawdust everywhere.

Despite being careful we ended up losing a bunch of paint from the engine cover.

Image

Once it started peeling off the engine cover I just kept at it until the whole thing was stripped back.

I don't think this is necessarily a bad thing. The rattle can paint job is still immaculate under there it looks like and I always had a far better finish with that than I got from the spray gun.

Image

The datasheet for the paint I used stated that I didn't need to prime this surface, apparently it lies. The paint came off in sheets, almost like a vinyl wrap being peeled off.

We lost a small bit from the nearside door too, only a tiny patch though. Think my response to this is basically *shrug* and "so be it." I'll stick to rattle cans in future to touch other areas in. Will mean I need to do the work outside and will cost more but the results seem worth it. Plus my compressor having died makes the spray gun kind of useless just now. I think my poor results with the spray gun are probably down to an inadequate air supply to be honest. I'm not bothered anyway as I knew the paint job was never going to be a long term result and she's rather scruffy anyway.

At least it's a complete panel that's done this so it's not *massively* obvious at a glance.
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#663 Post by Zelandeth » Mon Aug 10, 2020 11:12 pm

Been one of those days. Aside from seeing 34C in the shade in our lounge which is a surefire was to put me in a bad mood, the fleet have been misbehaving.

Firstly the Invacar while still driving perfectly decided to drop the pin out of the gear selector linkage for the second time since she's been back on the road.

Image

Hardly the end of the world, and I really should inspect the belt anyway and check the tightness of the pulley bolts given we've covered a couple of hundred miles since that lot was apart now. I really need to find a proper substitute for the original roll pin and R clip. I'd hoped that using a locknut on a bolt would do the job, but as we've now lost two it's obviously not.

Thankfully we were in drive when this happened and as the car weighs about as much as a postage stamp I just pushed it a couple of feet back out of the parking space when I discovered that I was lacking in a gear selector.

I'll see if I can summon the willpower to sort that out tomorrow.

Given I lacked a reverse gear I returned to base and grabbed the van to complete the errand run I was out on. When getting home I noticed diesel dripping off several points and that the back of the van was soaked.

Image

As far as I can see there's no sign of any leaks underneath. My guess is that the ridiculous temperature here today has just heated the air in the tank up enough to generate sufficient pressure that it's just forced it back out of the filler (which attaches to the tank about half way up and has a poor venting arrangement). The seal on the cap doesn't look too clever so I'll get a new one ordered. Obviously I need to look at the tank vent too...that involves dropping the tank though, which currently contains somewhere in the region of 70 litres of diesel.

Obviously she's going nowhere though until I'm sure that's been resolved.

Wanting to get something useful done I decided to have a crack at sorting the offside door on the Invacar. The window runner is knackered, the weatherstrip the glass sits in is 50% missing, and the top of the door skin and frame aren't properly anchored to each other which means the door has as much structural integrity as soggy cardboard. You can see daylight under the window frame too. On the plus side I had a spare window channel in stock which while not perfect was a lot better than the one on the car.

Image

I had seriously forgotten what a massive faff this job is since I did the other door.

It's not really difficult as such...just incredibly awkward and requiring things to be done in exactly the right sequence. Especially when you're trying to get the glass back in. You have to get both panes seated in the top runner, then position them into the bottom one and slide it into place as one unit. After the best part of three hours we're now at this stage.

Image

The window runner now has a thick foam pad under it, the remains of all the original fasteners have been removed so it can seat flush with the door too, and it's loosely bolted down at both ends.

Next step is to feed my hand into the miniscule gap to reach the end of the bolts inside the door cavity (there's not an opening under the black rail, you need to reach up from the one in the middle of the door, up around the latch actuator rods, door handle assembly etc, to thread washers and nuts onto the bolts then tighten the whole lot up. Oh, and reattach the window catches.

The channel is at least reasonably straight, the old one was utterly mangled.

Image

Hopefully this should vastly reduce the degree to which this door rattles and vastly improve the weather resistance. Need to track down some more window catches (think they're early Mini ones) as all but one of mine are cracked, then also need to track down a replacement for the window edge strip which should sit on the rear edge of the front window to keep draughts out. I've got the one on the nearside by the offside one was so rotten as to be useless.

Really not a fun job...even when it's a sane temperature. Will be really nice to have it done though as being able to see daylight through the door really bugs me - plus the whole door rattles horrendously.
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#664 Post by Zelandeth » Tue Aug 11, 2020 9:49 pm

After the better part of three hours and my nearly passing out from heat exhaustion twice this morning, finally the offside window runner is now sorted.

Image

Which at first glance looks very like the last photo from yesterday - if you look closely though you can see how the window rail has now been evenly clamped down to the door top which has helped remove the slight bend it had in it before.

For the sake of completeness, here's a "before" photo looking at the bottom of the window runner from inside the car (photo is of the nearside door, but they had identical issues).

Image

Looking at the same spot now at the front and rear of the door:

Image

Image

The only thing I still need to do there is to put a blob of sealant in the end of the stainless steel channel so that water is forced to drain through the dedicated drain holes rather then just running out of the front or back of the channel, straight over the inside of the door.

A bit of paint wouldn't go amiss either but that's a bit further down the priority list.

The channel rubber is pretty knackered but is far better than what was in there before which was about 40% missing. This does at least securely hold the glass now, whereas the window panes could rattle both in the frame and against each other before.

Image

Very much hoping that this is a job I won't need to do again.

Not content with having lost half my body weight in sweat in the morning, I ventured back into the garage in the afternoon.

My willingness to do anything besides hide in front of an air conditioner when it's anywhere north of about 20C outside is next to non existent under normal circumstances.

I'm trying to maintain momentum with this though so dragged myself back outside. I've really been enjoying buzzing around in this little car the last couple of days now I think I'm starting to get a better feel for it. I don't want to end up putting off sorting things and ending up another year down the line with it barely getting used.

Having got the door back together it was time to reattach the gear selector to the gearbox.

This job is most easily done from underneath, though jacking the car up would have meant taking the car out of the garage and working beneath the deadly ball of death that is the sun today. Not happening.

I wanted to inspect the pulleys, CVT belt and check the oil levels in the gearbox and diff - all of these things want the rear service hatch in the cabin out, so figured I'd just work from above like last time.

Image

When the new pulley set was installed a few hundred miles ago there was quite a bit of surface oxidisation on the primary pulley, I'm glad to report that just normal use appears to have resolved that. They've both got a lovely satin smooth texture now which is exactly what you want.

Image

Belt also seems happy enough. The manual states very clearly that cracking between the teeth on the belt will happen early during its life, is absolutely normal and shouldn't be considered a sign of impending failure, so I'm not worried about that. It still seems nicely pliable and there aren't any signs of fraying around the edges or anything like that.

Image

It's really noticeable that before the pulleys were replaced that this whole area used to get covered in finely atomised belt material during any run. No noticeable deposits anywhere since last time I was in here though so that behaviour seems to have been purely down to surface corrosion on the old secondary pulley.

The gear selector was originally attached to the selector arm on the box by a roughly 1/4" diameter roll pin, held in place by a split pin. I was missing this because the replacement selector I fitted (the original one in TPA was totally siezed) didn't have it, and no amount of effort was able to shift the original one from the linkage. Originally I fitted a bolt in this location and used a locknut arrangement to try to stop it loosening itself over time. Apparently this didn't work as since then I've lost two bolts.

Annoyingly the replacements I have, presumably because they're a metric size, don't fit. The smallest size I've got that fits drops straight through, the next size up won't fit. Adding an extra washer to the smaller one adds enough length that I can't then get the split pin in. So we will need to use a bolt then for the time being.

It was at this point I had a bit of a brainwave. There are two pivot joints on the gear linkage of this type. The lower one (the source of my problem) attaches to a rod which acts as a see-saw before attaching to the gear selector on the gearbox itself nearer the top of the box.

So I took the standard coupler out of the top pivot and installed that in the hard to get to bottom location. I then fitted a bolt and lock nut to the top one.

Image

The fact that I can actually get to it makes it possible to easily do the locknut up *way* more tightly than I probably managed last time. I also put a blob of thead lock on it.

At least if it does drop off again in future replacing the thing will be a five minute job as it's dead easy to get at.

I do get the impression that I may need to look at replacing the gearbox seals at some point though...

Image

Yes, I am indeed still out of gloves.

The box has always been quite oily but never actually seems to drip anything so I'm not worrying about this too much in the short term but it would be nice to get that sorted.

While I had access to the rear of the bulkhead because the service hatch was out I also replaced the self tapping screws that were holding the fire extinguisher bracket in place as they had (unsurprisingly) stripped their holes out so the thing wobbled around madly and rattled while driving. Bolts and nice big washers were instead employed which has made the extinguisher sit far more securely in place and far less likely to launch itself off the bulkhead if I were to brake too sharply. Given how loose the screws were I'm honestly surprised it hadn't already done so.

I'd been literally dripping with sweat since about two minutes after leaving the house so called time at this point before I wound up passing out from heat exhaustion (showing 36C in the garage by the time I called it). I'll check the gearbox and diff oil levels tomorrow before I button the service hatch back up and call this round of work done.
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#665 Post by Zelandeth » Fri Aug 14, 2020 12:13 am

Finally got around to getting something done today which had been bugging me since the day that TPA first started rolling again.

Image

They're pretty cheap and nasty but will do the job just fine. It's not as though I'm going to be commuting daily in the dark. Hopefully somewhere down the line I'll come across a better quality more in-period set of 7" H4 headlights. They certainly look more at home in the car than the clear ones which I've had in here until now though!

Image

Halfway there...

Image

Done. Doesn't that look better?

Image

Before I called it done on the offside door I wanted to get one last issue ticked off while I still had the drill and such out - that the upper runner channel (normally held on by several tiny self tapping screws) had pulled out of the door at the front.

Image

I drilled a couple of new holes and secured it with proper bolts with large penny washers behind the panel to better spread the load. Hopefully that won't cause is any issues in the future. I'll need to "massage" the front of that rail back into shape just a bit but that's a lower priority that can just stay on the whiteboard to do list for now.

Then once I'd re-secured the door seal in a few places where it had fallen off I called it good in that area for now.

Image

That door is still a pig to get closed sometimes and doesn't run properly on the lower runner so I will need to pull the whole lot apart at some point. I think that the rollers are knackered or seized to the axle they sit on.

While I was fiddling with door seals I re-secured the one on the nearside door which had started to peel off yet again. I've given up on gluing these in now after the third or fourth time and have just screwed it to the frame. Yes, I know that's not how the did it at the factory...but I'm sick of having to clean everything off and try a different type of adhesive every two months...and Sikaflex seems like overkill which is about the only thing I can think of I've not tried yet...Though I suspect it would just pull the gel coat off the fibreglass which is what I've already had happen in a couple places even with less powerful adhesives.

Image

I do actually have a full set of new door seals for this car which I'll probably get fitted soon as these are a bit dog eared in places. It's a pretty low priority though.

Before I put the rear service hatch back in I checked the oil level in both the diff and the gearbox and despite the visible leak they were both still showing as spot on. Before I actually put the hatch back in through I wanted to make an improvement to the fittings for that.

Originally this was secured by moderately large self tapping screws which screwed into spring clips behind the panel - all but two of these had dissolved in my case and required me to drill them out to get the panel off. Trying to get the screws into the bottom two holes is also nigh on impossible given that I can't just pull the back of the seat off with two bolts because I'm not using the original seat. Even having replaced the spring clips in there I've found that the screws tend to loosen themselves off over time as well.

My solution was to stick a bolt through from the back side, sandwiching the bulkhead panel between two big washers, essentially giving me studs attached to the bulkhead which I can then bolt the cover down onto.

Image

This is the first time that I've ever actually had this really solidly secured in place I think. It made getting the thing in way, way easier as it just slotted onto the bolts rather than having to spend forever trying to wriggle it around until all the holes line up and I can get the screws in. I'll be curious to see if this has had any impact on the noise level in the cabin.

Just need to finish tidying up my tools and such tomorrow and then we should be able to get her out and about again.
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#666 Post by Zelandeth » Sat Aug 15, 2020 12:31 am

First order of business for today was clearing up the huge mess in the interior from the work over the last couple of days. Easy enough. Getting interior photos is so much easier now I've got access to a wide angle lens...

Image

Then we were able to go out for a wander. Didn't actually check the odometer before I headed out, but pretty sure we clocked up north of 40 miles today in all driving conditions from bumbling around Newport Pagnell Town Centre to blatting along the A421. Absolutely cannot fault her performance today whatsoever.

I'm glad to report that having the service cover on the rear bulkhead properly bolted in place has slightly reduced the drivetrain noise, but has *massively* reduced the squeaks and rattles in the cabin. It's really only the doors which make a din in that regard now, and there's really nothing you can do about that as the bulk of it actually seems to come from the latches vibrating against the striker plates. There's no way to get them to fit snug enough to not rattle *and* be possible to close without body-slamming into them from outside the car. It's just a limitation of the design...and is something I may have a think about in the future if I find myself using the car as much as I think I might.

Here's a photo of her resting in the scenic surroundings of the Kingston Tesco car park.

Image

Being absolutely honest, I'm staggered by how capable this little car is now the engine is running right given their reputation. The brakes are getting way better with use as well, I think a lot of the dead feel in them has just been the shoes needing to bed in - which on a 400kg car takes a bit of time - having been able to do a few higher speed runs I think has helped there too.

She's looking far better now we've got period looking headlights to match the number plates which were fitted about a year ago. She's getting there.

Image

Image

It's really obvious how much better the paint finish I got with the aerosol cans I painted the engine cover with is...Think I'll be going back to that going forward. A year or three down the line I will probably get some of the worst bits of the bodywork professionally sorted out. On the plus side there's another Model 70 within 20 miles of where I live now which has a pretty tidy body, so we should be able to get some moulds made to *properly* sort the front corners and rear apron. Rather than the foam sculpted front corners and totally freehand fibreglass-over-cardboard rear apron.

Image

That's not a crack under the nearest tail light by the way. I ended up with odd rusty coloured runs in a lot of places after she was washed, that's all that is. It will wipe off with a damp rag.

The fact of the matter really is that I wasn't really wanting to throw serious money at the bodywork until I was convinced that the car was going to be a keeper - but over the last couple of days seeing how she drives when the engine is actually delivering all 20bhp properly - that's pretty much decided I think.

One thing I did want to test out today was how she would handle maintaining speed on a hill, as I know this is an issue that another owner has had with their Invacar a bit. The only reasonable hill around here on a faster road is on the A421 heading out of MK towards Bedford. Glad to report that on that hill she dropped from 60 to a steady 56mph which I think is perfectly reasonable. I'm generally going to be happy bumbling along at 50-55 most of the time anyway, just nice to know she's capable of getting a shift on when needed - especially given that on the grid roads in MK you kind of need to or you're just a moving roadblock ready to end up embedded in the radiator of someone's Audi. She really doesn't like doing 40, she'll creep up towards 50 is you take your eye off her for a second.

This also gave me a good opportunity to check something I'd been wanting to, which was how the oil temperature was doing when she was working hard. I'd previously painted the base of the oil pickup strainer plate matt black so I could get an accurate reading with an IR thermometer for this very reason. This reading was taken literally the moment I parked up, engine still running.

Image

That's absolutely fine I think. Not really a huge surprise given the size of the oil cooler and fan on this thing compared to the engine, but nevertheless it's nice to know. For comparison, on the oil temperature gauge I've got that would put the needle about 1/3 along the scale...right about where I'd generally want to see a temperature gauge sitting. Perfect!

I'll need to be out again at the weekend most likely, and if so I'll try to get another video showing how she is behaving now. It's astonishing how much less rattle and clatter there is in the cabin now I've got that service hatch properly secured.
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#667 Post by Zelandeth » Sat Aug 15, 2020 10:40 pm

I had reason to look back at some of my historic photos of TPA earlier today...and realised that it's easy to forget how far she has come.

June 2018 Vs August 2020:

Image

Image


Image

Image


Image

Image

There are definitely bits of the bodywork I want to revisit in the future, but she's definitely come a long way...
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

Dick
Posts: 504
Joined: Wed Sep 11, 2019 7:31 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#668 Post by Dick » Sun Aug 16, 2020 9:27 am

That's a tidy job, :thumbs:

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#669 Post by Zelandeth » Mon Aug 17, 2020 9:43 pm

TPA has been out and about again, continuing the theme of being the most unusual car in the carpark wherever she is.

Image

Had the smug satisfaction this afternoon of making use of how narrow the Invacar is when I found two cars both encroaching on the space between them - yet still had plenty of space to be able to slot into the gap. I'd forgotten how satisfying doing that is. It used to be a favourite pastime when I had the Cappuccino.

About thirty seconds after I took that photo (note the foreboding looking clouds) we had one of the most biblical downpours I've seen since moving down here descend on us just as I was leaving that carpark. At this point I learned something: Driving through hail in a tiny fibreglass car is LOUD.

As the rain started coming down heavily enough that it reduced visibility to essentially zero and surface water started to become an issue I decided to just pull over and wait for the worst of it to pass.

Image

Once things died down to a sensible level and the surface water had receeded to the point where I could see the road again we continued.

Despite a few folks having cautioned me on how poor these tyres are I didn't notice any issues today even when dealing with quite heavy surface water. Definitely was using caution though as I knew with so little weight on the front it wouldn't take much at all to cause aquaplaning.

The novelty of looking in the rear view mirror and seeing three rather than two clear bands of road behind you on a wet surface will take a while to wear off.

The weatherproofing is definitely massively improved over when I got the car but still needs work. Some water is still finding a way in around the nearside of the windscreen (though at least far enough over to clear my knees now) and I will obviously need to put some rubber washers under the bolts holding the window runner channel down as it drips into the door cavity along the bolts themselves. Overall though given the absolutely torrential level of the downpour it wasn't bad at all. The windscreen leak is the one which needs the most urgently sorting though as it has the potential to drip into my shoes. If I can get the windscreen leak fully sorted it's probably good enough for the sort of use this car will be getting to be honest.
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

User avatar
Zelandeth
Posts: 578
Joined: Fri Aug 18, 2017 9:11 pm

Re: Zel's Fleet Blog...Jag, Citroen, Mercedes, Sinclair & AC Model 70

#670 Post by Zelandeth » Tue Aug 18, 2020 9:08 pm

I had a bit of a moment of realisation today, that while I had changed the diff oil and topped up the gearbox oil, I hadn't actually changed the gearbox oil - because there's no drain plug (not massively surprising as there's a diff in the way). I'd always intended to vac the oil out to change it completely, but according to my whiteboard it hadn't yet been done. Until today.

Image

The oil in general wasn't bad but it looked like there was some darker gunk removed from the bottom.

Ever wanted to see what's inside an Invacar gearbox?

Image

Then with nice fresh oil in.

Image

The oil may well be nearly as old as the car for all I know.

Image

I can't remember if it was on here or another forum where someone asked me if I made a point of keeping a fire extinguisher onboard and accessible...In answer to that question: Yes. Right behind my right elbow.

Image

I really want to get the floor covering sorted out. The rubber matting really is shot in my case.

Image

This will be getting replaced with something a little more comfortable. I really don't like the rubber matting, not least because it's really slippery in the lateral direction and I've nearly gone face first into the tarmac when getting out of the car. As a result I'll be swapping it out for carpet (which should help a lot with the in-cabin noise levels I reckon), will be keeping it pretty discreet so a medium dark grey short pile material. I know it's not original, but I actually want to use this car and this is the sort of thing which will make it more pleasant for me. There are plenty of immaculate ones in museums if that's your thing.

I definitely will be reverting to my earlier approach where paint is concerned...Not so much because the new paint has adhered so poorly to the existing paint in some areas, but because the finish there was so much better.

Image

Image

I've learned quite a few things since I started out, so we should be able to get a better finish now than we originally saw. The car's also generally presentable enough that I don't mind doing a bit of work panel-by-panel going forward.
My website - aka. My *other* waste of time
Current fleet: 73 AC Model 70. 85 Sinclair C5. 85 Jaguar XJ-S V12 HE. 90 Mercedes 208D AutoTrail Navajo. 96 Citroen Xantia Activa.

Post Reply

Who is online

Users browsing this forum: No registered users and 13 guests