Alvis TA-14 restoration story so far

Post pictures and stories about your cars both present and past. Also post up "blogs" on your restoration projects - the more pictures the better! Note: blog-type threads often get few replies, but are often read by many members, and provide interest and motivation to other enthusiasts so don't be disappointed if you don't get many replies.
Message
Author
User avatar
TerryG
Posts: 6750
Joined: Wed Jan 05, 2011 1:54 pm
Location: East Midlands

Re: Alvis TA-14 restoration story so far

#11 Post by TerryG » Mon Feb 28, 2011 9:59 pm

That looks amazing. you have the patience of a saint!
bnicho wrote:My problem is I get stuck into concentrating on the job and forget all about the camera.
My problem is i take plenty of pictures at the start then my hands get dirty and i don't want to get the camera dirty so i stop taking snaps.
Understeer: when you hit the wall with the front of the car.
Oversteer: when you hit the wall with the back of the car.
Horsepower: how fast you hit the wall.
Torque: how far you take the wall with you.

User avatar
spiderbloke
Posts: 87
Joined: Tue Feb 08, 2011 2:01 pm
Location: Gatwick - Surrey

Re: Alvis TA-14 restoration story so far

#12 Post by spiderbloke » Tue Mar 01, 2011 11:43 am

It sounds daft but I tie two sandwich bags on long strings to the tripod so that I can slip my hands into them and take a photo when needed. As I said, daft, but effective.
So many broken bits, So little time

User avatar
JPB
Posts: 9800
Joined: Fri Jan 07, 2011 3:24 pm

Re: Alvis TA-14 restoration story so far

#13 Post by JPB » Tue Mar 01, 2011 5:53 pm

spiderbloke wrote:It sounds daft but I tie two sandwich bags on long strings to the tripod so that I can slip my hands into them and take a photo when needed. As I said, daft, but effective.
Daft? No. That has to be one of the best ideas that I wish I'd thought of. Hmm, no excuses for not taking photos next time I'm doing something vaguely interesting under a car.
John, Operating knackered old sheds as daily transport since 1981. :|

pryantcc
Posts: 289
Joined: Wed Jan 05, 2011 6:35 pm

Re: Alvis TA-14 restoration story so far

#14 Post by pryantcc » Tue Mar 01, 2011 8:01 pm

TerryG wrote:That looks amazing. you have the patience of a saint!
Thanks for the comments guys! Terry, it's slow going alright. I'm not actually that good with patience, but I do have a healthy dose of determination! I just keep telling myself that every tiny thing I do is one step closer to being able to drive this thing around!

I love the camera tip, even having it on a tripod is a good idea, that way it's always there! I primed a door today & have a photo of it un-painted and painted, nothing else! What a glorious day though. The sun was hot enough to help my paint flash off. I had been using a heat lamp which was not designed for the job, but today I thought "Why not use the big heat lamp in the sky?!" Haven't had any complaints from neighbours yet about the smell, the wife was moaning that I stink though! :roll:

User avatar
spiderbloke
Posts: 87
Joined: Tue Feb 08, 2011 2:01 pm
Location: Gatwick - Surrey

Re: Alvis TA-14 restoration story so far

#15 Post by spiderbloke » Wed Mar 02, 2011 11:38 am

Thanks for the positive comments on the sarnie bag trick guys. I used to work for a studio that did a lot of promotional material so I had a fair amount of site based photography to do. I picked up a couple of bags once when the required shot came up unexpected while my hands were covered in mud and have used them ever since.
I have to admit that my concentration levels are not what they should be sometimes and if I didn't take shedloads of shots of each process I'd lose my way very quickly.
The other tip I've picked up from workshop photography sessions is to use a longer focal length lens and stand further away. I lost count of the number of times that essential detail was lost due to reflection and flare from the flash going off.
So many broken bits, So little time

pryantcc
Posts: 289
Joined: Wed Jan 05, 2011 6:35 pm

Re: Alvis TA-14 restoration story so far

#16 Post by pryantcc » Fri Mar 18, 2011 6:42 pm

So, I tightened it all up and gave her a whirl on the crank handle and hey-presto, 100psi in all 4 cylinders! Phew!!

Then I was so excited, I stuck all the bits back on. Loads of photos here, no commentry required I think. Photos of engine stuff:


Image

Image

Image

Image

Image

Image.
Last edited by pryantcc on Wed Aug 02, 2017 2:51 pm, edited 1 time in total.

kamilb1998
Posts: 46
Joined: Sun Jan 23, 2011 9:38 am
Contact:

Re: Alvis TA-14 restoration story so far

#17 Post by kamilb1998 » Fri Mar 18, 2011 8:06 pm

That sure will be a lovely car when finished! Look forward to more pics. :D
Kamil


What are dreams for, if not to come true?
1988 Jaguar XJ40 Sovereign 3.6

pryantcc
Posts: 289
Joined: Wed Jan 05, 2011 6:35 pm

Re: Alvis TA-14 restoration story so far

#18 Post by pryantcc » Mon Apr 04, 2011 6:20 pm

We decided that we were going to move back to my home town from Scotland to Ireland. Way more effort went into getting the garage gear & the car shifted than did for any of the house stuff! I assembled the car as much as made sense so I could transport it all in one piece and fill it up with bits at the same time!

I fitted the bulkhead, pretty straightforward, 8 bolts onto the chassis outriggers. This could be permanent as I shouldn't have to remove it again for anything (I hope!).

Image

Image

Image


I also reunited the body tub with the chassis. It was a bit of a struggle on my own with only an engine crane for assistance, but finally fitted without any damage.

Image

Image



I reckon the chassis has been bent slightly upwards behind the rear axle (a hammering effect has been caused by up-rated springs and a lack of bump stops! When the car goes light, the axle contacts the chassis & I reckon the spring tension has been bending it up at the back with every whack!) as the doors are about ¾ of an inch too low when I attach them. I hope to rectify this with an RSJ, a bottle jack and some strong straps. Yikes!

Image

Image

So, I trailored it to Ireland (note garage door under car for fitment on arrival). It sat in the garage without love for the best part of a year while loads of work was done around the new house. I had a guy come and look at it with a view to painting it. His quote at the time convinced me that I could affourd to have it professionally sprayed, so I got stuck into getting it to a paintable stage!
I trial fitted the front wings (they are slightly different shapes as they are spares from two different cars), bonnet and radiator grill so that I could see what needs doing before it’s all cleaned up and painted. It’s very encouraging to see the car like this!, I feel like I really might be getting closer to the finish line! Sorry for the poor photo, I took it with my phone.

Image
Last edited by pryantcc on Wed Aug 02, 2017 2:51 pm, edited 1 time in total.

pryantcc
Posts: 289
Joined: Wed Jan 05, 2011 6:35 pm

Re: Alvis TA-14 restoration story so far

#19 Post by pryantcc » Fri Apr 29, 2011 3:05 pm

I spent an obscene amount of money getting some of my brightwork re-done back in June last year. There's more to do but I'm way too poor at the moment. Here's a before and after of the radiator cowl, I love it!!

Image

Image

Now, back to the task of getting it to a point where I start to stick chrome back on!
I had one final structural piece of timber to fit across the rear of the body, behind the back bumper and under the boot. I made up a couple of brackets to attach it with, cleaned and painted them up.

Image

I was waiting to fit this until I could get a couple of cracks in the aluminium welded up. I also needed to fit a plate over the hole someone had cut to fit a tow bar!

Image

You can see the black timber which I made up sitting on the chassis rails in the photo below
Image

So, I got one of those Duraweld kits which turned out to be relatively successful. The cracks were welded, the timber fitted and the chassis re-united with the body for what will hopefully be the last time!
Attention has now turned to painting. It was way too cold to do it without added heat, so I decided I'll do whatever prep I can, beat out and fill the dents, prepare and prime everything. That way, when the weather gets a bit warmer, I won't have so much to do to get things ready for some colour! A few patches were welded into the wings, then I got stuck into stripping the doors back to bare metal as I figured these would be an easy way to start and pick up some skills before I move onto the complex curves!

Image

Image

Image

That’s it, much more stripping, filling and priming to follow, then hopefully when the weather warms up a little, I can decide on a colour and go for it! This story is almost up to date now. I have primed 4 or 5 panels, and learning all the way!
Last edited by pryantcc on Wed Aug 02, 2017 2:51 pm, edited 1 time in total.

Mash
Posts: 38
Joined: Sat May 07, 2011 9:59 pm

Re: Alvis TA-14 restoration story so far

#20 Post by Mash » Sat May 07, 2011 10:03 pm

This looks great :) I started restoring an Alvis TA14 (Mulliners saloon) last year and it's encouraging to see yours taking shape. Got to say that radiator cowl looks perfect! Did you have the badge re-enamelled?
Matt

Post Reply

Who is online

Users browsing this forum: Zelandeth and 1 guest